tmtmtmtm / malaysian_parliament

Members of the Parliament of Malaysia


This is a scraper that runs on Morph. To get started see the documentation

Contributors tmtmtmtm

Last run failed with status code 255.

Console output of last run

Injecting configuration and compiling...  -----> Ruby app detected -----> Compiling Ruby -----> Using Ruby version: ruby-2.4.1 -----> Installing dependencies using bundler 1.15.2  Running: bundle install --without development:test --path vendor/bundle --binstubs vendor/bundle/bin -j4 --deployment  Warning: the running version of Bundler (1.15.2) is older than the version that created the lockfile (1.15.4). We suggest you upgrade to the latest version of Bundler by running `gem install bundler`.  Fetching gem metadata from https://rubygems.org/.........  Fetching version metadata from https://rubygems.org/..  Fetching dependency metadata from https://rubygems.org/.  Fetching https://github.com/everypolitician/combine_popolo_memberships.git  Fetching https://github.com/everypolitician/scraped.git  fatal: Could not parse object '1eb50450da29ff6ec00cd99ac4bb109474147bce'.  Git error: command `git reset --hard 1eb50450da29ff6ec00cd99ac4bb109474147bce`  in directory  /tmp/build/vendor/bundle/ruby/2.4.0/bundler/gems/scraped-1eb50450da29 has  failed.  If this error persists you could try removing the cache directory  '/tmp/build/vendor/bundle/ruby/2.4.0/cache/bundler/git/scraped-4aebd6454f7f48898bb4e4442c6d8f78e3f53aaa'  Bundler Output: Warning: the running version of Bundler (1.15.2) is older than the version that created the lockfile (1.15.4). We suggest you upgrade to the latest version of Bundler by running `gem install bundler`.  Fetching gem metadata from https://rubygems.org/.........  Fetching version metadata from https://rubygems.org/..  Fetching dependency metadata from https://rubygems.org/.  Fetching https://github.com/everypolitician/combine_popolo_memberships.git  Fetching https://github.com/everypolitician/scraped.git  fatal: Could not parse object '1eb50450da29ff6ec00cd99ac4bb109474147bce'.  Git error: command `git reset --hard 1eb50450da29ff6ec00cd99ac4bb109474147bce`  in directory  /tmp/build/vendor/bundle/ruby/2.4.0/bundler/gems/scraped-1eb50450da29 has  failed.  If this error persists you could try removing the cache directory  '/tmp/build/vendor/bundle/ruby/2.4.0/cache/bundler/git/scraped-4aebd6454f7f48898bb4e4442c6d8f78e3f53aaa'  !  ! Failed to install gems via Bundler.  !

Data

Downloaded 6 times by everypolitician tmtmtmtm MikeRalphson

To download data sign in with GitHub

Download table (as CSV) Download SQLite database (449 KB) Use the API

rows 10 / 2498

name party area term source
Zahidi Bin Zainul Abidin, Y.B. Datuk
BN - UMNO
Padang Besar
13
Shaharuddin Bin Ismail, Y.B. Ir.
BN - UMNO
Kangar
13
Shahidan Bin Kassim, Y.B. Dato' Seri Dr.
BN - UMNO
Arau
13
Nawawi Bin Ahmad, Y.B. Dato' Ir.
BN - UMNO
Langkawi
13
Othman Bin Aziz, Y.B. Dato'
BN - UMNO
Jerlun
13
Mohd Johari Bin Baharum, Y.B. Dato' Wira
BN - UMNO
Kubang Pasu
13
Mahdzir Bin Khalid, Y.B. Dato' Seri
BN - UMNO
Padang Terap
13
Mahfuz Haji Omar, Y.B. Dato' Haji
PAS
Pokok Sena
13
Gooi Hsiao-Leung, Y.B.
PKR
Alor Setar
13
Azman Ismail, Y.B. Dr.
PKR
Kuala Kedah
13

Statistics

Average successful run time: 1 minute

Total run time: about 13 hours

Total cpu time used: 14 minutes

Total disk space used: 484 KB

History

  • Auto ran revision 61a08f8d and failed .
    nothing changed in the database
  • Auto ran revision 61a08f8d and failed .
    nothing changed in the database
  • Auto ran revision 61a08f8d and failed .
    nothing changed in the database
  • Auto ran revision 61a08f8d and failed .
    nothing changed in the database
  • Auto ran revision 61a08f8d and failed .
    nothing changed in the database
  • ...
  • Created on morph.io

Show complete history

Scraper code

Ruby

malaysian_parliament / scraper.rb