tmtmtmtm / canada-house-of-commons-wikipedia

Scrapes en.wikipedia.org

Wikipedia, the free encyclopedia


Contributors tmtmtmtm

Last run failed with status code 1.

Console output of last run

Injecting configuration and compiling...  -----> Ruby app detected -----> Compiling Ruby -----> Using Ruby version: ruby-2.3.3 -----> Installing dependencies using bundler 1.15.2  Running: bundle install --without development:test --path vendor/bundle --binstubs vendor/bundle/bin -j4 --deployment  Warning: the running version of Bundler (1.15.2) is older than the version that created the lockfile (1.16.0). We suggest you upgrade to the latest version of Bundler by running `gem install bundler`.  Fetching gem metadata from https://rubygems.org/.........  Fetching version metadata from https://rubygems.org/..  Fetching dependency metadata from https://rubygems.org/.  Fetching https://github.com/everypolitician/combine_popolo_memberships.git  Fetching https://github.com/everypolitician/scraped.git  Fetching https://github.com/everypolitician/scraped_page_archive.git  Fetching https://github.com/everypolitician/scraper_test.git  Fetching https://github.com/openaustralia/scraperwiki-ruby.git  Fetching https://github.com/everypolitician/table_unspanner.git  Fetching https://github.com/everypolitician/wikidata-fetcher.git  Fetching https://github.com/everypolitician/wikidata_ids_decorator.git  Fetching rake 12.3.0  Fetching public_suffix 3.0.1  Fetching ast 2.3.0  Installing ast 2.3.0  Installing public_suffix 3.0.1  Installing rake 12.3.0  Using bundler 1.15.2  Fetching coderay 1.1.2  Installing coderay 1.1.2  Fetching colorize 0.8.1  Using combine_popolo_memberships 0.2.0 from https://github.com/everypolitician/combine_popolo_memberships.git (at master@5769841)  Fetching safe_yaml 1.0.4  Installing colorize 0.8.1  Fetching diskcached 1.1.3  Installing safe_yaml 1.0.4  Fetching unf_ext 0.0.7.4  Fetching excon 0.60.0  Installing diskcached 1.1.3  Fetching execjs 2.7.0  Installing excon 0.60.0  Installing execjs 2.7.0  Fetching multipart-post 2.0.0  Installing multipart-post 2.0.0  Installing unf_ext 0.0.7.4 with native extensions  Fetching field_serializer 0.3.0  Installing field_serializer 0.3.0  Fetching git 1.3.0  Installing git 1.3.0  Fetching hashdiff 0.3.7  Installing hashdiff 0.3.7  Fetching hashie 3.5.7  Installing hashie 3.5.7  Fetching httpclient 2.8.3  Fetching json 2.1.0  Installing json 2.1.0 with native extensions  Installing httpclient 2.8.3  Fetching method_source 0.9.0  Installing method_source 0.9.0  Fetching mime-types-data 3.2016.0521  Installing mime-types-data 3.2016.0521  Fetching mini_portile2 2.3.0  Installing mini_portile2 2.3.0  Fetching minitest 5.10.3  Installing minitest 5.10.3  Fetching vcr 3.0.3  Installing vcr 3.0.3  Fetching netrc 0.11.0  Installing netrc 0.11.0  Fetching open-uri-cached 0.0.5  Installing open-uri-cached 0.0.5  Fetching parallel 1.12.1  Installing parallel 1.12.1  Fetching powerpack 0.1.1  Installing powerpack 0.1.1  Fetching rainbow 3.0.0  Installing rainbow 3.0.0  Fetching require_all 1.4.0  Installing require_all 1.4.0  Fetching ruby-progressbar 1.9.0  Installing ruby-progressbar 1.9.0  Fetching unicode-display_width 1.3.0  Installing unicode-display_width 1.3.0  Fetching sqlite3 1.3.13  Installing sqlite3 1.3.13 with native extensions  Fetching yajl-ruby 1.3.1  Installing yajl-ruby 1.3.1 with native extensions  Fetching parser 2.4.0.2  Installing parser 2.4.0.2  Fetching addressable 2.5.2  Installing addressable 2.5.2  Fetching crack 0.4.3  Installing crack 0.4.3  Fetching faraday 0.13.1  Installing faraday 0.13.1  Fetching pry 0.11.3  Installing pry 0.11.3  Fetching mime-types 3.1  Installing mime-types 3.1  Fetching nokogiri 1.8.1  Installing nokogiri 1.8.1 with native extensions  Fetching minispec-metadata 2.0.0  Installing minispec-metadata 2.0.0  Fetching minitest-around 0.4.0  Installing minitest-around 0.4.0  Fetching unf 0.1.4  Installing unf 0.1.4  Fetching rubocop 0.52.0  Installing rubocop 0.52.0  Fetching webmock 2.0.3  Installing webmock 2.0.3  Fetching faraday_middleware 0.12.2  Installing faraday_middleware 0.12.2  Fetching sqlite_magic 0.0.6  Installing sqlite_magic 0.0.6  Fetching minitest-vcr 1.4.0  Installing minitest-vcr 1.4.0  Fetching domain_name 0.5.20170404  Installing domain_name 0.5.20170404  Fetching vcr-archive 0.3.0  Installing vcr-archive 0.3.0  Using scraper_test 0.1.0 from https://github.com/everypolitician/scraper_test.git (at master@9b4326c)  Fetching wikidata-client 0.0.12  Installing wikidata-client 0.0.12  Using scraperwiki 3.0.1 from https://github.com/openaustralia/scraperwiki-ruby.git (at morph_defaults@fc50176)  Fetching http-cookie 1.0.3  Using scraped_page_archive 0.5.0 from https://github.com/everypolitician/scraped_page_archive.git (at master@a998412)  Fetching wikisnakker 0.9.1  Using scraped 0.6.2 from https://github.com/everypolitician/scraped.git (at master@7fd4391)  Using table_unspanner 0.1.0 from https://github.com/everypolitician/table_unspanner.git (at master@a70a98a)  Installing http-cookie 1.0.3  Installing wikisnakker 0.9.1  Fetching faraday-cookie_jar 0.0.6  Fetching rest-client 2.0.2  Installing faraday-cookie_jar 0.0.6  Fetching mediawiki_api 0.7.1  Installing rest-client 2.0.2  Installing mediawiki_api 0.7.1  Using wikidata-fetcher 0.21.0 from https://github.com/everypolitician/wikidata-fetcher.git (at master@a2938a6)  Using wikidata_ids_decorator 0.2.0 from https://github.com/everypolitician/wikidata_ids_decorator.git (at master@77c536a)  Bundle complete! 20 Gemfile dependencies, 64 gems now installed.  Gems in the groups development and test were not installed.  Bundled gems are installed into ./vendor/bundle.  Post-install message from webmock:  WebMock 2.0 has some breaking changes. Please check the CHANGELOG: https://goo.gl/piDGLu  Bundle completed (40.15s)  Cleaning up the bundler cache.  Warning: the running version of Bundler (1.15.2) is older than the version that created the lockfile (1.16.0). We suggest you upgrade to the latest version of Bundler by running `gem install bundler`. -----> Installing node-v6.11.1-linux-x64 -----> Detecting rake tasks   -----> Discovering process types  Procfile declares types -> scraper Injecting scraper and running... scraper.rb:65:in `block in <class:MemberRow>': No such party: Qu├ębec Debout (RuntimeError) from /app/vendor/bundle/ruby/2.3.0/gems/field_serializer-0.3.0/lib/field_serializer.rb:26:in `block in to_h' from /app/vendor/bundle/ruby/2.3.0/gems/field_serializer-0.3.0/lib/field_serializer.rb:25:in `map' from /app/vendor/bundle/ruby/2.3.0/gems/field_serializer-0.3.0/lib/field_serializer.rb:25:in `to_h' from scraper.rb:137:in `map' from scraper.rb:137:in `block in <main>' from scraper.rb:135:in `each' from scraper.rb:135:in `<main>'

Statistics

Average successful run time: 1 minute

Total run time: about 16 hours

Total cpu time used: 37 minutes

Total disk space used: 278 KB

History

  • Auto ran revision 20e24915 and failed .
    nothing changed in the database
    17 pages scraped
  • Auto ran revision 20e24915 and failed .
    nothing changed in the database
  • Auto ran revision 20e24915 and failed .
    nothing changed in the database
    140 pages scraped
  • Auto ran revision 20e24915 and failed .
    nothing changed in the database
    17 pages scraped
  • Auto ran revision 20e24915 and failed .
    nothing changed in the database
  • ...
  • Created on morph.io

Show complete history