openaustralia / morph-division-postcode-correspondence

Scrapes AEC for electorate/postcode mapping.


Last run failed with status code 255.

Console output of last run

Injecting configuration and compiling...  -----> Node.js app detected  -----> Creating runtime environment   NPM_CONFIG_LOGLEVEL=error  NPM_CONFIG_PRODUCTION=true  NPM_CONFIG_CAFILE=/etc/ssl/certs/ca-certificates.crt  NODE_VERBOSE=false  NODE_ENV=production  NODE_TLS_REJECT_UNAUTHORIZED=0  NODE_MODULES_CACHE=true  -----> Installing binaries  engines.node (package.json): 5.8.0  engines.npm (package.json): 3.8.2   Resolving node version 5.8.0...  Downloading and installing node 5.8.0...  Bootstrapping npm 3.8.2 (replacing 3.7.3)...  npm 3.8.2 installed  -----> Restoring cache  Skipping cache restore (not-found)  -----> Building dependencies  Installing node modules (package.json)   > sqlite3@4.0.8 install /tmp/build/node_modules/sqlite3  > node-pre-gyp install --fallback-to-build   node-pre-gyp ERR! UNCAUGHT EXCEPTION  node-pre-gyp ERR! stack TypeError: this is not a typed array.  node-pre-gyp ERR! stack at Function.from (native)  node-pre-gyp ERR! stack at Unzip.write (/tmp/build/node_modules/minizlib/index.js:268:42)  node-pre-gyp ERR! stack at Unpack.write (/tmp/build/node_modules/tar/lib/parse.js:300:58)  node-pre-gyp ERR! stack at Request.ondata (stream.js:31:26)  node-pre-gyp ERR! stack at emitOne (events.js:90:13)  node-pre-gyp ERR! stack at Request.emit (events.js:182:7)  node-pre-gyp ERR! stack at IncomingMessage.<anonymous> (/tmp/build/node_modules/request/request.js:1080:12)  node-pre-gyp ERR! stack at emitOne (events.js:90:13)  node-pre-gyp ERR! stack at IncomingMessage.emit (events.js:182:7)  node-pre-gyp ERR! stack at readableAddChunk (_stream_readable.js:153:18)  node-pre-gyp ERR! System Linux 4.18.16-x86_64-linode118  node-pre-gyp ERR! command "/tmp/build/.heroku/node/bin/node" "/tmp/build/node_modules/.bin/node-pre-gyp" "install" "--fallback-to-build"  node-pre-gyp ERR! cwd /tmp/build/node_modules/sqlite3  node-pre-gyp ERR! node -v v5.8.0  node-pre-gyp ERR! node-pre-gyp -v v0.11.0  node-pre-gyp ERR! This is a bug in `node-pre-gyp`.  node-pre-gyp ERR! Try to update node-pre-gyp and file an issue if it does not help:  node-pre-gyp ERR! <https://github.com/mapbox/node-pre-gyp/issues>  morph-division-postcode-correspondence@1.0.0 /tmp/build  +-- cheerio@1.0.0-rc.3  | +-- css-select@1.2.0  | | +-- boolbase@1.0.0  | | +-- css-what@2.1.3  | | +-- domutils@1.5.1  | | `-- nth-check@1.0.2  | +-- dom-serializer@0.1.1  | | `-- domelementtype@1.3.1  | +-- entities@1.1.2  | +-- htmlparser2@3.10.1  | | +-- domhandler@2.4.2  | | +-- inherits@2.0.3  | | `-- readable-stream@3.3.0  | | `-- string_decoder@1.2.0  | +-- lodash@4.17.11  | `-- parse5@3.0.3  | `-- @types/node@12.0.1  +-- clone@1.0.4  +-- queue-async@1.2.1  `-- request@2.88.0  +-- aws-sign2@0.7.0  +-- aws4@1.8.0  +-- caseless@0.12.0  +-- combined-stream@1.0.8  | `-- delayed-stream@1.0.0  +-- extend@3.0.2  +-- forever-agent@0.6.1  +-- form-data@2.3.3  | `-- asynckit@0.4.0  +-- har-validator@5.1.3  | +-- ajv@6.10.0  | | +-- fast-deep-equal@2.0.1  | | +-- fast-json-stable-stringify@2.0.0  | | +-- json-schema-traverse@0.4.1  | | `-- uri-js@4.2.2  | | `-- punycode@2.1.1  | `-- har-schema@2.0.0  +-- http-signature@1.2.0  | +-- assert-plus@1.0.0  | +-- jsprim@1.4.1  | | +-- extsprintf@1.3.0  | | +-- json-schema@0.2.3  | | `-- verror@1.10.0  | | `-- core-util-is@1.0.2  | `-- sshpk@1.16.1  | +-- asn1@0.2.4  | +-- bcrypt-pbkdf@1.0.2  | +-- dashdash@1.14.1  | +-- ecc-jsbn@0.1.2  | +-- getpass@0.1.7  | +-- jsbn@0.1.1  | +-- safer-buffer@2.1.2  | `-- tweetnacl@0.14.5  +-- is-typedarray@1.0.0  +-- isstream@0.1.2  +-- json-stringify-safe@5.0.1  +-- mime-types@2.1.24  | `-- mime-db@1.40.0  +-- oauth-sign@0.9.0  +-- performance-now@2.1.0  +-- qs@6.5.2  +-- safe-buffer@5.1.2  +-- tough-cookie@2.4.3  | +-- psl@1.1.31  | `-- punycode@1.4.1  +-- tunnel-agent@0.6.0  `-- uuid@3.3.2   npm ERR! Linux 4.18.16-x86_64-linode118  npm ERR! argv "/tmp/build/.heroku/node/bin/node" "/tmp/build/.heroku/node/bin/npm" "install" "--unsafe-perm" "--userconfig" "/tmp/build/.npmrc"  npm ERR! node v5.8.0  npm ERR! npm v3.8.2  npm ERR! code ELIFECYCLE   npm ERR! sqlite3@4.0.8 install: `node-pre-gyp install --fallback-to-build`  npm ERR! Exit status 7  npm ERR!  npm ERR! Failed at the sqlite3@4.0.8 install script 'node-pre-gyp install --fallback-to-build'.  npm ERR! Make sure you have the latest version of node.js and npm installed.  npm ERR! If you do, this is most likely a problem with the sqlite3 package,  npm ERR! not with npm itself.  npm ERR! Tell the author that this fails on your system:  npm ERR! node-pre-gyp install --fallback-to-build  npm ERR! You can get information on how to open an issue for this project with:  npm ERR! npm bugs sqlite3  npm ERR! Or if that isn't available, you can get their info via:  npm ERR! npm owner ls sqlite3  npm ERR! There is likely additional logging output above.   npm ERR! Please include the following file with any support request:  npm ERR! /tmp/build/npm-debug.log  -----> Build failed   We're sorry this build is failing! You can troubleshoot common issues here:  https://devcenter.heroku.com/articles/troubleshooting-node-deploys   If you're stuck, please submit a ticket so we can help:  https://help.heroku.com/   Love,  Heroku 

Statistics

Total run time: less than a minute

Total cpu time used: less than 5 seconds

Total disk space used: 28 KB

History

  • Manually ran revision f8876406 and failed .
  • Created on morph.io