muzza1976 / greater_geelong

City of Greater Geelong Development Applications


Contributors muzza1976 mlandauer henare CloCkWeRX dependabot[bot]

Last run failed with status code 1.

Console output of last run

Injecting configuration and compiling...  -----> Ruby app detected -----> Compiling Ruby -----> Using Ruby version: ruby-2.5.1 -----> Installing dependencies using bundler version 1.15.2  Running: bundle install --without development:test --path vendor/bundle --binstubs vendor/bundle/bin -j4 --deployment  Warning: the running version of Bundler (1.15.2) is older than the version that created the lockfile (1.17.3). We suggest you upgrade to the latest version of Bundler by running `gem install bundler`.  Fetching gem metadata from https://rubygems.org/......  Fetching version metadata from https://rubygems.org/.  Fetching https://github.com/openaustralia/scraperwiki-ruby.git  Using bundler 1.15.2  Fetching connection_pool 2.2.3  Fetching unf_ext 0.0.7.7  Fetching httpclient 2.8.3  Installing connection_pool 2.2.3  Installing httpclient 2.8.3  Installing unf_ext 0.0.7.7 with native extensions  Fetching mime-types-data 3.2020.1104  Installing mime-types-data 3.2020.1104  Fetching net-http-digest_auth 1.4.1  Fetching mini_portile2 2.5.0  Installing net-http-digest_auth 1.4.1  Fetching racc 1.5.2  Installing mini_portile2 2.5.0  Fetching ntlm-http 0.1.1  Installing ntlm-http 0.1.1  Fetching webrick 1.7.0  Installing webrick 1.7.0  Installing racc 1.5.2 with native extensions  Fetching webrobots 0.1.2  Installing webrobots 0.1.2  Fetching sqlite3 1.4.2  Installing sqlite3 1.4.2 with native extensions  Fetching net-http-persistent 4.0.1  Installing net-http-persistent 4.0.1  Fetching mime-types 3.3.1  Installing mime-types 3.3.1  Fetching unf 0.1.4  Installing unf 0.1.4  Fetching domain_name 0.5.20190701  Installing domain_name 0.5.20190701  Fetching http-cookie 1.0.3  Installing http-cookie 1.0.3  Fetching sqlite_magic 0.0.6  Installing sqlite_magic 0.0.6  Using scraperwiki 3.0.1 from https://github.com/openaustralia/scraperwiki-ruby.git (at morph_defaults@fc50176)  Fetching nokogiri 1.11.1 (x86_64-linux)  Installing nokogiri 1.11.1 (x86_64-linux)  Fetching mechanize 2.7.7  Installing mechanize 2.7.7  Bundle complete! 2 Gemfile dependencies, 21 gems now installed.  Gems in the groups development and test were not installed.  Bundled gems are installed into ./vendor/bundle.  Bundle completed (15.50s)  Cleaning up the bundler cache.  Warning: the running version of Bundler (1.15.2) is older than the version that created the lockfile (1.17.3). We suggest you upgrade to the latest version of Bundler by running `gem install bundler`. -----> Detecting rake tasks   -----> Discovering process types  Procfile declares types -> scraper Injecting scraper and running... /app/vendor/bundle/ruby/2.5.0/gems/mechanize-2.7.7/lib/mechanize/http/agent.rb:329:in `fetch': 403 => Net::HTTPForbidden for https://www.geelongaustralia.com.au/advertisedplanning/default.aspx -- unhandled response (Mechanize::ResponseCodeError) from /app/vendor/bundle/ruby/2.5.0/gems/mechanize-2.7.7/lib/mechanize/http/agent.rb:998:in `response_redirect' from /app/vendor/bundle/ruby/2.5.0/gems/mechanize-2.7.7/lib/mechanize/http/agent.rb:321:in `fetch' from /app/vendor/bundle/ruby/2.5.0/gems/mechanize-2.7.7/lib/mechanize.rb:464:in `get' from scraper.rb:15:in `<main>'

Statistics

Total run time: 8 minutes

Total cpu time used: less than 5 seconds

Total disk space used: 39.4 KB

History

  • Manually ran revision 3187844c and failed .
  • Manually ran revision 3d961c34 and failed .
  • Manually ran revision 3d961c34 and failed .
  • Manually ran revision 3d961c34 and failed .
  • Created on morph.io

Scraper code

greater_geelong