morph-test-scrapers / node_template_test

Just a test, you can delete me


This is a scraper that runs on Morph. To get started see the documentation

Contributors henare

Last run completed successfully .

Console output of last run

Injecting configuration and compiling... -----> Node.js app detected  -----> Reading application state  package.json...  build directory...  cache directory...  environment variables...   Node engine: unspecified  Npm engine: unspecified  Start mechanism: Procfile  node_modules source: package.json  node_modules cached: false   NPM_CONFIG_PRODUCTION=true  NPM_CONFIG_CAFILE=/etc/ssl/certs/ca-certificates.crt  NODE_MODULES_CACHE=true  -----> Installing binaries  Resolving node version (latest stable) via semver.io...  Downloading and installing node 5.10.0...  Using default npm version: 3.8.3  -----> Building dependencies  No cache available  Installing node modules   > sqlite3@3.1.3 install /tmp/build/node_modules/sqlite3  > node-pre-gyp install --fallback-to-build   [sqlite3] Success: "/tmp/build/node_modules/sqlite3/lib/binding/node-v47-linux-x64/node_sqlite3.node" is installed via remote  /tmp/build  +-- cheerio@0.20.0  | +-- css-select@1.2.0  | | +-- boolbase@1.0.0  | | +-- css-what@2.1.0  | | +-- domutils@1.5.1  | | `-- nth-check@1.0.1  | +-- dom-serializer@0.1.0  | | `-- domelementtype@1.1.3  | +-- entities@1.1.1  | +-- htmlparser2@3.8.3  | | +-- domelementtype@1.3.0  | | +-- domhandler@2.3.0  | | +-- entities@1.0.0  | | `-- readable-stream@1.1.13  | | +-- core-util-is@1.0.2  | | +-- inherits@2.0.1  | | +-- isarray@0.0.1  | | `-- string_decoder@0.10.31  | +-- jsdom@7.2.2  | | +-- abab@1.0.3  | | +-- acorn@2.7.0  | | +-- acorn-globals@1.0.9  | | +-- cssom@0.3.1  | | +-- cssstyle@0.2.34  | | +-- escodegen@1.8.0  | | | +-- esprima@2.7.2  | | | +-- estraverse@1.9.3  | | | +-- esutils@2.0.2  | | | +-- optionator@0.8.1  | | | | +-- deep-is@0.1.3  | | | | +-- fast-levenshtein@1.1.3  | | | | +-- levn@0.3.0  | | | | +-- prelude-ls@1.1.2  | | | | +-- type-check@0.3.2  | | | | `-- wordwrap@1.0.0  | | | `-- source-map@0.2.0  | | | `-- amdefine@1.0.0  | | +-- nwmatcher@1.3.7  | | +-- parse5@1.5.1  | | +-- sax@1.2.1  | | +-- symbol-tree@3.1.4  | | +-- webidl-conversions@2.0.1  | | +-- whatwg-url-compat@0.6.5  | | | `-- tr46@0.0.3  | | `-- xml-name-validator@2.0.1  | `-- lodash@4.10.0  +-- request@2.70.0  | +-- aws-sign2@0.6.0  | +-- aws4@1.3.2  | | `-- lru-cache@4.0.1  | | +-- pseudomap@1.0.2  | | `-- yallist@2.0.0  | +-- bl@1.1.2  | | `-- readable-stream@2.0.6  | | +-- isarray@1.0.0  | | +-- process-nextick-args@1.0.6  | | `-- util-deprecate@1.0.2  | +-- caseless@0.11.0  | +-- combined-stream@1.0.5  | | `-- delayed-stream@1.0.0  | +-- extend@3.0.0  | +-- forever-agent@0.6.1  | +-- form-data@1.0.0-rc4  | | `-- async@1.5.2  | +-- har-validator@2.0.6  | | +-- chalk@1.1.3  | | | +-- ansi-styles@2.2.1  | | | +-- escape-string-regexp@1.0.5  | | | +-- has-ansi@2.0.0  | | | | `-- ansi-regex@2.0.0  | | | +-- strip-ansi@3.0.1  | | | `-- supports-color@2.0.0  | | +-- commander@2.9.0  | | | `-- graceful-readlink@1.0.1  | | +-- is-my-json-valid@2.13.1  | | | +-- generate-function@2.0.0  | | | +-- generate-object-property@1.2.0  | | | | `-- is-property@1.0.2  | | | +-- jsonpointer@2.0.0  | | | `-- xtend@4.0.1  | | `-- pinkie-promise@2.0.1  | | `-- pinkie@2.0.4  | +-- hawk@3.1.3  | | +-- boom@2.10.1  | | +-- cryptiles@2.0.5  | | +-- hoek@2.16.3  | | `-- sntp@1.0.9  | +-- http-signature@1.1.1  | | +-- assert-plus@0.2.0  | | +-- jsprim@1.2.2  | | | +-- extsprintf@1.0.2  | | | +-- json-schema@0.2.2  | | | `-- verror@1.3.6  | | `-- sshpk@1.7.4  | | +-- asn1@0.2.3  | | +-- dashdash@1.13.0  | | | `-- assert-plus@1.0.0  | | +-- ecc-jsbn@0.1.1  | | +-- jodid25519@1.0.2  | | +-- jsbn@0.1.0  | | `-- tweetnacl@0.14.3  | +-- is-typedarray@1.0.0  | +-- isstream@0.1.2  | +-- json-stringify-safe@5.0.1  | +-- mime-types@2.1.10  | | `-- mime-db@1.22.0  | +-- node-uuid@1.4.7  | +-- oauth-sign@0.8.1  | +-- qs@6.1.0  | +-- stringstream@0.0.5  | +-- tough-cookie@2.2.2  | `-- tunnel-agent@0.4.2  `-- sqlite3@3.1.3  +-- nan@2.2.1  `-- node-pre-gyp@0.6.25  +-- mkdirp@0.5.1  | `-- minimist@0.0.8  +-- nopt@3.0.6  | `-- abbrev@1.0.7  +-- npmlog@2.0.3  | +-- ansi@0.3.1  | +-- are-we-there-yet@1.1.2  | | +-- delegates@1.0.0  | | `-- readable-stream@2.0.6  | | +-- core-util-is@1.0.2  | | +-- inherits@2.0.1  | | +-- isarray@1.0.0  | | +-- process-nextick-args@1.0.6  | | +-- string_decoder@0.10.31  | | `-- util-deprecate@1.0.2  | `-- gauge@1.2.7  | +-- has-unicode@2.0.0  | +-- lodash.pad@4.1.0  | | +-- lodash.repeat@4.0.0  | | `-- lodash.tostring@4.1.2  | +-- lodash.padend@4.2.0  | | +-- lodash.repeat@4.0.0  | | `-- lodash.tostring@4.1.2  | `-- lodash.padstart@4.2.0  | +-- lodash.repeat@4.0.0  | `-- lodash.tostring@4.1.2  +-- rc@1.1.6  | +-- deep-extend@0.4.1  | +-- ini@1.3.4  | +-- minimist@1.2.0  | `-- strip-json-comments@1.0.4  +-- request@2.69.0  | +-- aws-sign2@0.6.0  | +-- aws4@1.3.2  | | `-- lru-cache@4.0.1  | | +-- pseudomap@1.0.2  | | `-- yallist@2.0.0  | +-- bl@1.0.3  | | `-- readable-stream@2.0.6  | | +-- core-util-is@1.0.2  | | +-- inherits@2.0.1  | | +-- isarray@1.0.0  | | +-- process-nextick-args@1.0.6  | | +-- string_decoder@0.10.31  | | `-- util-deprecate@1.0.2  | +-- caseless@0.11.0  | +-- combined-stream@1.0.5  | | `-- delayed-stream@1.0.0  | +-- extend@3.0.0  | +-- forever-agent@0.6.1  | +-- form-data@1.0.0-rc4  | | `-- async@1.5.2  | +-- har-validator@2.0.6  | | +-- chalk@1.1.3  | | | +-- ansi-styles@2.2.1  | | | +-- escape-string-regexp@1.0.5  | | | +-- has-ansi@2.0.0  | | | | `-- ansi-regex@2.0.0  | | | +-- strip-ansi@3.0.1  | | | | `-- ansi-regex@2.0.0  | | | `-- supports-color@2.0.0  | | +-- commander@2.9.0  | | | `-- graceful-readlink@1.0.1  | | +-- is-my-json-valid@2.13.1  | | | +-- generate-function@2.0.0  | | | +-- generate-object-property@1.2.0  | | | | `-- is-property@1.0.2  | | | +-- jsonpointer@2.0.0  | | | `-- xtend@4.0.1  | | `-- pinkie-promise@2.0.0  | | `-- pinkie@2.0.4  | +-- hawk@3.1.3  | | +-- boom@2.10.1  | | +-- cryptiles@2.0.5  | | +-- hoek@2.16.3  | | `-- sntp@1.0.9  | +-- http-signature@1.1.1  | | +-- assert-plus@0.2.0  | | +-- jsprim@1.2.2  | | | +-- extsprintf@1.0.2  | | | +-- json-schema@0.2.2  | | | `-- verror@1.3.6  | | `-- sshpk@1.7.4  | | +-- asn1@0.2.3  | | +-- dashdash@1.13.0  | | | `-- assert-plus@1.0.0  | | +-- ecc-jsbn@0.1.1  | | +-- jodid25519@1.0.2  | | +-- jsbn@0.1.0  | | `-- tweetnacl@0.14.3  | +-- is-typedarray@1.0.0  | +-- isstream@0.1.2  | +-- json-stringify-safe@5.0.1  | +-- mime-types@2.1.10  | | `-- mime-db@1.22.0  | +-- node-uuid@1.4.7  | +-- oauth-sign@0.8.1  | +-- qs@6.0.2  | +-- stringstream@0.0.5  | +-- tough-cookie@2.2.2  | `-- tunnel-agent@0.4.2  +-- rimraf@2.5.2  | `-- glob@7.0.3  | +-- inflight@1.0.4  | | `-- wrappy@1.0.1  | +-- inherits@2.0.1  | +-- minimatch@3.0.0  | | `-- brace-expansion@1.1.3  | | +-- balanced-match@0.3.0  | | `-- concat-map@0.0.1  | +-- once@1.3.3  | | `-- wrappy@1.0.1  | `-- path-is-absolute@1.0.0  +-- semver@5.1.0  +-- tar@2.2.1  | +-- block-stream@0.0.8  | +-- fstream@1.0.8  | | `-- graceful-fs@4.1.3  | `-- inherits@2.0.1  `-- tar-pack@3.1.3  +-- debug@2.2.0  | `-- ms@0.7.1  +-- fstream@1.0.8  | +-- graceful-fs@4.1.3  | `-- inherits@2.0.1  +-- fstream-ignore@1.0.3  | +-- inherits@2.0.1  | `-- minimatch@3.0.0  | `-- brace-expansion@1.1.3  | +-- balanced-match@0.3.0  | `-- concat-map@0.0.1  +-- once@1.3.3  | `-- wrappy@1.0.1  +-- readable-stream@2.0.6  | +-- core-util-is@1.0.2  | +-- inherits@2.0.1  | +-- isarray@1.0.0  | +-- process-nextick-args@1.0.6  | +-- string_decoder@0.10.31  | `-- util-deprecate@1.0.2  `-- uid-number@0.0.6   npm WARN build No description  npm WARN build No repository field.  npm WARN build No license field.  -----> Checking startup method  Found Procfile  -----> Finalizing build  Creating runtime environment  Exporting binary paths  Cleaning npm artifacts  Cleaning previous cache  Caching results for future builds  -----> Build succeeded!   /tmp/build  +-- cheerio@0.20.0  +-- request@2.70.0  `-- sqlite3@3.1.3   WARNING: Node version not specified in package.json  https://devcenter.heroku.com/articles/nodejs-support#specifying-a-node-js-version  -----> Discovering process types  Procfile declares types -> scraper Injecting scraper and running... 1: J. Pablo Pérez Trabucco 2: Will Ockenden 3: Professor Wendy Bacon

Data

Downloaded 1 time by MikeRalphson

To download data sign in with GitHub

Download table (as CSV) Download SQLite database (2 KB) Use the API

rows 3 / 3

name
J. Pablo Pérez Trabucco
Will Ockenden
Professor Wendy Bacon

Statistics

Average successful run time: 2 minutes

Total run time: 2 minutes

Total cpu time used: less than 5 seconds

Total disk space used: 20.7 KB

History

  • Manually ran revision 15654135 and completed successfully .
    3 records added in the database
  • Created on morph.io

Scraper code

Node.js

node_template_test / scraper.js