Contributors blablupcom

Last run completed successfully .

Console output of last run

Injecting configuration and compiling...  -----> Python app detected  ! The latest version of Python 2 is python-2.7.14 (you are using python-2.7.6, which is unsupported).  ! We recommend upgrading by specifying the latest version (python-2.7.14).  Learn More: https://devcenter.heroku.com/articles/python-runtimes -----> Installing python-2.7.6 -----> Installing pip -----> Installing requirements with pip  Obtaining scraperwiki from git+http://github.com/openaustralia/scraperwiki-python.git@morph_defaults#egg=scraperwiki (from -r /tmp/build/requirements.txt (line 1))  Cloning http://github.com/openaustralia/scraperwiki-python.git (to morph_defaults) to /app/.heroku/src/scraperwiki  Collecting lxml==3.4.4 (from -r /tmp/build/requirements.txt (line 2))  /app/.heroku/python/lib/python2.7/site-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py:318: SNIMissingWarning: An HTTPS request has been made, but the SNI (Subject Name Indication) extension to TLS is not available on this platform. This may cause the server to present an incorrect TLS certificate, which can cause validation failures. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.io/en/latest/security.html#snimissingwarning.  SNIMissingWarning  /app/.heroku/python/lib/python2.7/site-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py:122: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.io/en/latest/security.html#insecureplatformwarning.  InsecurePlatformWarning  Downloading lxml-3.4.4.tar.gz (3.5MB)  Collecting cssselect==0.9.1 (from -r /tmp/build/requirements.txt (line 3))  Downloading cssselect-0.9.1.tar.gz  Collecting beautifulsoup4 (from -r /tmp/build/requirements.txt (line 4))  Downloading beautifulsoup4-4.6.0-py2-none-any.whl (86kB)  Collecting python-dateutil (from -r /tmp/build/requirements.txt (line 5))  Downloading python_dateutil-2.6.1-py2.py3-none-any.whl (194kB)  Collecting dumptruck>=0.1.2 (from scraperwiki->-r /tmp/build/requirements.txt (line 1))  Downloading dumptruck-0.1.6.tar.gz  Collecting requests (from scraperwiki->-r /tmp/build/requirements.txt (line 1))  Downloading requests-2.18.4-py2.py3-none-any.whl (88kB)  Collecting six>=1.5 (from python-dateutil->-r /tmp/build/requirements.txt (line 5))  Downloading six-1.11.0-py2.py3-none-any.whl  Collecting chardet<3.1.0,>=3.0.2 (from requests->scraperwiki->-r /tmp/build/requirements.txt (line 1))  Downloading chardet-3.0.4-py2.py3-none-any.whl (133kB)  Collecting certifi>=2017.4.17 (from requests->scraperwiki->-r /tmp/build/requirements.txt (line 1))  Downloading certifi-2017.11.5-py2.py3-none-any.whl (330kB)  Collecting urllib3<1.23,>=1.21.1 (from requests->scraperwiki->-r /tmp/build/requirements.txt (line 1))  Downloading urllib3-1.22-py2.py3-none-any.whl (132kB)  Collecting idna<2.7,>=2.5 (from requests->scraperwiki->-r /tmp/build/requirements.txt (line 1))  Downloading idna-2.6-py2.py3-none-any.whl (56kB)  Installing collected packages: dumptruck, chardet, certifi, urllib3, idna, requests, scraperwiki, lxml, cssselect, beautifulsoup4, six, python-dateutil  Running setup.py install for dumptruck: started  Running setup.py install for dumptruck: finished with status 'done'  Running setup.py develop for scraperwiki  Running setup.py install for lxml: started  Running setup.py install for lxml: still running...  Running setup.py install for lxml: finished with status 'done'  Running setup.py install for cssselect: started  Running setup.py install for cssselect: finished with status 'done'  Successfully installed beautifulsoup4-4.6.0 certifi-2017.11.5 chardet-3.0.4 cssselect-0.9.1 dumptruck-0.1.6 idna-2.6 lxml-3.4.4 python-dateutil-2.6.1 requests-2.18.4 scraperwiki six-1.11.0 urllib3-1.22   ! Hello! It looks like your application is using an outdated version of Python.  ! This caused the security warning you saw above during the 'pip install' step.  ! We recommend 'python-3.6.2', which you can specify in a 'runtime.txt' file.  ! -- Much Love, Heroku.   -----> Discovering process types  Procfile declares types -> scraper Injecting scraper and running... E2001_EROYC_gov_2017_10 E2001_EROYC_gov_2017_09 E2001_EROYC_gov_2017_08 E2001_EROYC_gov_2017_07 E2001_EROYC_gov_2017_06 E2001_EROYC_gov_2017_05 E2001_EROYC_gov_2017_04 E2001_EROYC_gov_2017_03 E2001_EROYC_gov_2017_02 E2001_EROYC_gov_2017_01 E2001_EROYC_gov_2016_12 E2001_EROYC_gov_2016_11 E2001_EROYC_gov_2016_10 E2001_EROYC_gov_2016_09 E2001_EROYC_gov_2016_08 E2001_EROYC_gov_2016_06 E2001_EROYC_gov_2016_06 E2001_EROYC_gov_2016_05 E2001_EROYC_gov_2016_04 E2001_EROYC_gov_2016_03 E2001_EROYC_gov_2016_02 E2001_EROYC_gov_2016_01 E2001_EROYC_gov_2015_12 E2001_EROYC_gov_2015_11 E2001_EROYC_gov_2015_10 E2001_EROYC_gov_2015_09 E2001_EROYC_gov_2015_08 E2001_EROYC_gov_2015_07 E2001_EROYC_gov_2015_06 E2001_EROYC_gov_2015_05 E2001_EROYC_gov_2015_04 E2001_EROYC_gov_2015_03 E2001_EROYC_gov_2015_02 E2001_EROYC_gov_2015_01 E2001_EROYC_gov_2014_12 E2001_EROYC_gov_2014_11 E2001_EROYC_gov_2014_10 E2001_EROYC_gov_2014_09 E2001_EROYC_gov_2014_08 E2001_EROYC_gov_2014_07 E2001_EROYC_gov_2014_06 E2001_EROYC_gov_2014_05 E2001_EROYC_gov_2014_04 E2001_EROYC_gov_2014_03 E2001_EROYC_gov_2014_02 E2001_EROYC_gov_2014_01 E2001_EROYC_gov_2013_12 E2001_EROYC_gov_2013_11 E2001_EROYC_gov_2013_10 E2001_EROYC_gov_2013_09 E2001_EROYC_gov_2013_08 E2001_EROYC_gov_2013_07 E2001_EROYC_gov_2013_06 E2001_EROYC_gov_2013_05 E2001_EROYC_gov_2013_04 E2001_EROYC_gov_2013_03 E2001_EROYC_gov_2013_02 E2001_EROYC_gov_2013_01 E2001_EROYC_gov_2012_12 E2001_EROYC_gov_2012_11 E2001_EROYC_gov_2012_10 E2001_EROYC_gov_2012_09 E2001_EROYC_gov_2012_08 E2001_EROYC_gov_2012_07 E2001_EROYC_gov_2012_06 E2001_EROYC_gov_2012_05 E2001_EROYC_gov_2012_04 E2001_EROYC_gov_2012_03 E2001_EROYC_gov_2012_02 E2001_EROYC_gov_2012_01 E2001_EROYC_gov_2011_12 E2001_EROYC_gov_2011_11 E2001_EROYC_gov_2011_10 E2001_EROYC_gov_2011_09 E2001_EROYC_gov_2011_08 E2001_EROYC_gov_2011_07 E2001_EROYC_gov_2011_06 E2001_EROYC_gov_2011_05 E2001_EROYC_gov_2011_04 E2001_EROYC_gov_2011_03 E2001_EROYC_gov_2011_02 E2001_EROYC_gov_2011_01 E2001_EROYC_gov_2010_12 E2001_EROYC_gov_2010_11

Data

Downloaded 4 times by blablupcom

To download data sign in with GitHub

Download table (as CSV) Download SQLite database (34 KB) Use the API

rows 10 / 84

l f d
E2001_EROYC_gov_2017_10
2017-12-08 19:06:47.476213
E2001_EROYC_gov_2017_09
2017-12-08 19:06:47.916256
E2001_EROYC_gov_2017_08
2017-12-08 19:06:48.295192
E2001_EROYC_gov_2017_07
2017-12-08 19:06:48.665539
E2001_EROYC_gov_2017_06
2017-12-08 19:06:49.011766
E2001_EROYC_gov_2017_05
2017-12-08 19:06:49.356258
E2001_EROYC_gov_2017_04
2017-12-08 19:06:49.744633
E2001_EROYC_gov_2017_03
2017-12-08 19:06:50.103574
E2001_EROYC_gov_2017_02
2017-12-08 19:06:50.500028
E2001_EROYC_gov_2017_01
2017-12-08 19:06:51.019875

Statistics

Average successful run time: 2 minutes

Total run time: 6 minutes

Total cpu time used: less than 5 seconds

Total disk space used: 92.4 KB

History

  • Manually ran revision e7dd1ed3 and completed successfully .
    84 records added in the database
  • Manually ran revision 3e2dbdd1 and completed successfully .
    10 records added in the database
  • Manually ran revision 3e2dbdd1 and completed successfully .
    84 records added in the database
  • Created on morph.io

Scraper code

Python

sp_E2001_EROYC_gov / scraper.py