This is a scraper that runs on Morph. It scrapes lodged development applications from the Brisbane City Council in support of the Planningalerts.org.au project.

Contributors shangzhipan

Last run failed with status code 255.

Console output of last run

Injecting configuration and compiling...  -----> Node.js app detected  -----> Creating runtime environment   NPM_CONFIG_LOGLEVEL=error  NPM_CONFIG_PRODUCTION=true  NPM_CONFIG_CAFILE=/etc/ssl/certs/ca-certificates.crt  NODE_VERBOSE=false  NODE_ENV=production  NODE_TLS_REJECT_UNAUTHORIZED=0  NODE_MODULES_CACHE=true  -----> Installing binaries  engines.node (package.json): 14.15.3  engines.npm (package.json): unspecified (use default)   Resolving node version 14.15.3...  Error: Invalid semantic version "14.15.3"  -----> Build failed   ! Invalid semver requirement   Node, Yarn, and npm adhere to semver, the semantic versioning convention  popularized by GitHub.   http://semver.org/   However you have specified a version requirement that is not a valid  semantic version.   https://kb.heroku.com/why-is-my-node-js-build-failing-because-of-an-invalid-semver-requirement 

Statistics

Total run time: less than 20 seconds

Total cpu time used: less than 5 seconds

Total disk space used: 74.2 KB

History

  • Manually ran revision 326589f0 and failed .
  • Created on morph.io

Scraper code

Node.js

BCC_scrape / scraper.js